Robotics and GPS/GIS in 4-H: Workplace Skills for the 21% Century

Interpolation

Visiting every location in a field to make land related measurements is usually difficult or
expensive. So such measurements are conducted at strategically dispersed locations, and
predicted values are assigned to all other locations. Input points can be either randomly or
regularly spaced or based on some sampling scheme. Surface interpolation functions create a
continuous surface from sampled point values. In this activity, an interpolated surface is created
to visualize distribution of Phosphorous (P value) content across the field.

Explorer’s Guide

Before You Start

Line up according to height. Then, have 2-3 students leaved the line. Knowing the height of those
who remain standing the next to the vacant places, estimate what the height of absent students
should be. Use averaging techniques (1-2 taller and 1-2 shorter students). This method is the
simplest form of interpolation in one dimension (along one line).

Learning by Doing

1. Start ArcMap and go to Tool > Extensions to turn on the Spatial Analyst Extension as shown
below. Add Boundary.shp to the map.

Select the extenzions yau want to use.

30 Analyst

ArcScan

[rata Interoperability
Geostatistical Analyst
M aplex

Metwork &nalyzt
Publisher
Schematics

Spatial Analpzt

Survey Analyst
Survey Editar

Tracking Analyst

O .--OROO0O0O0O0=xOfd

Description:

Spatial Analyst 9.2
Copyright ©1333-2006 ESRI Inc. All Rights Rezerved

Frovides spatial analysis tools for uze with raster and feature data.

About Extensions
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Add Data
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2. To add soil analysis data into this map go to Tool > Add XY data. Make sure you select the
excel worksheet file as shown below.

Add XY Data

A table containing ¥ and ' coordinate data can be added to the
map az a layer

Choose a table from the map or biowse for another table:

I Soil_analysis$ Ll?]

Specify the fields faor the » and ' coordinates:
# Field: I Longitude ;I
¥ Field: I Latitude ;I

i~ Coordinate Syetem of [nput Coordinates

Description:

Unknown Coordinate System

[ Shaw Details Edit... |

v wam me if the resulting layer will have restricted functionality

l 0K l Cancel |
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3. To assign a coordinate system go to Edit and Select Geographic Coordinate System > World
> WGS 1984.prj . Your XY data should now have the spatial reference as indicated below.

Browse for Coordinate System rz| Browse for Coordinate System

Lok ir: |D wiord

Look in: |@ Coordinate Systems

ITRF 1986.pri (0 [TRF 2000.pr

(ZdProjected Conrdinate Systems (I ITRF 1989.pri Eimswe 9z-2.pri
B ITRF 1990.pri B wiGs 1966.pri
B ITRF 1991.pri B wes 1972.pri

(N ITRE 1992.prj {wiEs 1972 TBE pri
T ITRF 1993.prj "

(I ITRF 1994.pri

B ITRF 1996 pri

(N ITRE 1997 pri

Hame: |Gaographic Coardinate Systems Add Narme: |W’GS 194, pij Add

Show of lype: |Cao|d\nata Systerns j Cancel Shaw of type: |Ennrdmate Systems j Cancel

Spatial Reference Properties

Hr' Coordinate System
Hame; GCS_WGES_1984

Dretails:

Angular Uit Degree [0.017453232519943259]
Prime Meridian; Greerwich [0.000000000000000000)
Dratum; 0_wGES_1984
Spheroid; 'wWGS_1984
Semimajor A=is: 5378137.000000000000000000
Semiminor Axis: 6356752.314245173300000000
Inverse Flattening: 298,257 223563000030000

Select a predefined coordinate spstem.

Import a coordinate system and X/7, £ and M
Impaort... domaing from an existing geodataset [e.q..
feature dataset, feature class, raster).

Create a new coordinate system,

Modify Edit the properties of the cumrently selected
i coordinate system.

LClear Sets the coordinate system to Unknowe,

_ mport_|
_ Moy |
_ Cea |
_sawess. |

Save ds. . Save the coordinate system to a file.

[ QK ] Cancel Apply

4. Click Apply and OK .Click OK in the Add XY data dialog box as shown below.
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Add XY Data

A table containing < and ' coordinate data can be added to the
map az a layer

Choose a table from the map or browse for anather table:
Soil_analysis$ j El

— Specify the fields for the % and Y coordingtes ——————————————
# Field:

I Longitude LI

¥ Field: | Latitude [=]

— Coordinate System of Input Coordinates

Description:

Geographic Coordinate System:
Name: GCS_WGS_1984

[ Show Detail:

v wiarm me if the resulting laper will have resticted functionalty

Ok Cancel

5. Your map should be as given below.

. Map_interpolation - ArcMap - ArcView

J Eile Edit View Insert Selection Tools Window Help

|DSE8 L =8 oo $ftm ] &@0|N
| prawing = K (0 & O~ Alx 2 6] i it <] Bz u Av & d- =~

|k @5 EEO0 SB[ " E|a| @@ e @@ ®akonsa? |

= £F Layers
= Soi_analysis$ Events o
-

2 @ Boundary
|

Dizplay Sourcel Selection

@02 4]

1+

| |710608.967 4559916.767 Meters

6. Right Click on the soil analysis XY data you just added and go to Data > Export Data to
convert this data to shapefile. Click Yes to add this exported data to the map as a layer.
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Export Data

E wpart: Al features ;I

Uze the zame coordinate system az
0 this layer's source data

" the data frame

" the feature dataszet you export the data inta
[only applies if you export to & feature dataset in a geodatabaze]

Output shapefile or feature class:

IE:\4H-GISyear2‘xD atah 5 oilanalysis. shil @l

0k I Cancel

7. Now you need to change the projection of this layer before doing interpolation. Go to

ArcToolbox and go to Data Management Tools > Projections and Transformations > Feature
> Project as shown below.

Arc Toolbox

= Map_interpolation - ArcMap - ArcView

J File Edit View Insert Selection Tools Wwindow Help ‘
LI R A AT =11

|vawng v K (0 O Al~] % [alael ][0 ] B 7 U Av & Fr v~
EEEEEEEE D e EE D R LR R T A

&=

1=

g arcTookhox A
-89 30 Analyst Tocls

- &P Analysis Toals

= Soil_analysis$ Events = a Cartography Tools
* &9 Convversion Tacls

=] Boundary % Data Interoperability Tools
-

B a Data Management Taols

% Diaka Comparison

& Datahase

@ Disconnected Editing

-8 Domains

: & Feature Class

@ Features

& Fields

@ File Geodatabase

& ceneral

& Generalization

@ Indexes

+ % Joins

& Layers and Table Yiews

E| @ Projections and Transformations
H & Feature

2 Batch Praject

}" Create Spatial Reference

) Create Custom Geographic Transformatio
ﬁ Define Projection

Raster
@ Subtypes
+- & Table
N ST —— o)
ol i} I E =l
= — -
Display | Source | Selection Favarites | Index | Search Hesu\lsl |? o2 [ I_
Convert a geographic dataset between two coordinate systems.

| |709838.817 4559903,355 Meters

8. Double click Project and make sure you select the soil analysis layer file as the input file. To

specify the output coordinate system click select > Projected coordinate system > Utm >
WGS 1984 >WGS 1984 UTM Zone 14N.prj as shown below.
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Browse for Coordinate System

Look in: |0 ‘wigs 1984 | H ;}| | H_

@WGS 1954 Complex UTM Zone 290, prj @WGS 1984 UTM Zone 1335.prj

@WGS 1954 Complex UTM Zone 300, prj

@WGS 1954 UTM Zone 10M.prj @WGS 1984 UTM Zone 145.prj

i wES 1984 UTM Zone 105.pri BwiEs 1984 UTM Zane 158, pri

i waS 1984 UTH Zane 110.prj wiEs 1984 UTM Zone 155.pri

i wES 1984 UTH Zone 115.prj wiEs 1984 UTM Zane 168, pr

i uas 1984 UTM Zone 120 pri {BnEs 1984 UTM Zone 165.pr

i was 1984 UTM Zone 125,00 {BnEs 1984 UTM Zone 170, pr

{BGS 1984 UTM Zone 130.pri wEs 1984 UTM Zone 175.pri wGs
< | >
Mame: [WGS 1954 UTH Zone 14M.pri Add

Show of type: |Cooldinate Systems j Caneel

9. Your Project dialog box should be as shown below.

* Project
A | ) Help
Input Dataset or Feature Class i
[ Saitanalysis | D”j Output Coordinate
System
Input Coordinate System {optional)
|GE 51954 e The coordinate system to

be applied to the Output
CQutput Dataset or Feature Class Dataset or Feature Class.

] CiY4H-GISyear2\Datah Soilanalysis_Project.shp D""]

Oukput Coordinate System
1WG 5_1984_UTHM_Zone_14M

Geographic Transformation {optional)

xlx

|

0k Cancel E nvironments. .. | << Hide Help

10. Click OK and this will take some time to project the feature class. Exit Arc Toolbox. Your
screen should look like this.

Activity 28 6



Robotics and GPS/GIS in 4-H: Workplace Skills for the 21* Century

Map_interpolation - ArcMap - ArcView.
J File Edit View Insert Selection Tools Window Help |
EELEER Y SR e T T =10
[owm~ k0 @O A= am  cdf <8z u|Av - Lr oe
[@@E BEI0$R0F J)&@E &) @@uuO0@es Bo koM 27 |

= £F Layers
a8 Sol

.
= Snilanalysis
.
= Soil_analysis$ Events
®

= Boundary
|
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Display | Saurce Se\ecnonl lem |~ B

| [710615.525 4560269.797 Meters

11. Remove the soilanalysis and soil_analysis$ Events as you have a projected shapefile of solil
analysis data. Right click the layer on the layer panel and click remove. Your screen should

be as indicated below.

Map_interpolation - ArcMap - ArcView

Eile Edit View Insert Selection Tools Window Help |

|
EELCE R TIEE) o I L E10d
J
J

Drawing ¥ k@|gjﬂjﬂ‘@md ~[ [0~ B 1 Q|A' He v o~
RRAP BICA EF0F ] @E @ @aiciO@es®mo k 04 L a7 |

EE=]
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12. Make sure you have added the spatial analyst tool to your map. You are now ready to do the

interpolation.

13. In Spatial Analyst toolbar go to Options and specify the working directory as shown below.

General l E:-:tent] Cell Size]

working directony: ||::\4H-|3|5year2mata

- &

Analysiz mask: | <Mone>

Analyziz Coordinate System

{o Analysis output will be saved in the same coordinate
system az the input [or first raster input if there are
multiple inputs).

" Analypsis output will be zaved in the same coordinate
zystem az the active data frame.

v Dizplay warning message if raster inputs have o be
projected during analysis operation.

(1] 4 Cancel

14. Go to Extent tab and select the same as Layer “Boundary” as given below. Select Maximum
of Inputs for the cell size.

Options

Genera| Cell Size ]

Analpziz extent;

Lett;

Same as Layer "Boundar Jid

Tom 4BE0460.92
709843.605
Battam: 45589911.45

Options
General] Extent Cell Size l

Apalysiz cell size:

M amimurm of lnputs

Bight:

710564.934

Snap extent to:

|<None>

el

Cancel

=)

Cancel |

15. Click OK when done. Go to Spatial Analyst > Interpolate to Raster > Inverse Distance

Weighted. Specify the Z value as “P” and output cell size as “5". Specify the output raster
directory as indicated below.
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Inverse Distance Weighted E|E|
Input paints: (Solanalsis_Poiect  +| ]
Z vale field: B ~1)
Power: 2
Search radius ype: Wariahle |

Search Radiuz Settings

MHurnber of paints: 12
b zxirmunn distatice:

[ Use barier pallines: | J
Output cell zize:
Dutput raster [F\aH GlSyearZiDatabiDw_sa

| ak. I Cancel |

16. Interpolation will take some time. To clip the interpolation surface within the field boundary,
Go to View > Data Frame Properties and enable clip to shape as shown below. This will clip
the grid to the extent of the field boundary, deleting every pixel of the interpolated surface
outside the field boundary.

Data Frame Properties

Annotation Groups ] Extent Rectangles ] Frame ] Size and Position ]
General Coordinate System ] llurninaticn ] Grids ] Map Cache ]

Extent

" Automnatic

" Fixed Scale

™ Fixed Egtent

Top: |
Left: Biht: |

B ottormn: |

Clip to Shape

[|7 Enable |; Speciy Shape... |I Border:

Extent Used By Full Extent Command

% Estent of data in all lapers (D efault]

" Other:

I 0K I Cancel |I Apply I

17. Change the symbology of the interpolated surface. For this go to layer properties and
navigate to symbology tab. Right click on Labels and go to format labels. Specify 0 decimal
points as shown below. Click Apply and OK. Change the symbology of the boundary
shapefile to view it along with other layers.
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Layer Properties

General | Source | Etent | Displa] Svmbology IFields | Joins & Relates

™ Use hillshade effect

Z:Il—

hDW' e | Draw raster grouping values into classes Impork. .. |
Stretched
~Fields Classification
Yalue: I YALLE = ;I Equal Interval
Mormalization: I sMone = LI Classes: m Classify...
Color Ramp: I- R A j
Symbol | Range I Label I ~
I = 0654912 - 10.31973373 3-10
1031973373 - 1763291833 11-15 =
1763291533 - 2494010294 19-25 1
24.94610294 - 32,25925754 26 - 32 =
32.259925794 - 39.57247215 F3-40
39.57247215 - 46,88565675 41 - 47
[ 45 RREFSATS - B4 10RR4136 4R - 54 ]
™ Show class breaks using cell values Display MoData as |v|

=)

Cancel | l Spply I

18. Your screen should be similar to the one given below.

. Map_interpolation - ArcMap - ArcView

J File Edi Yiew Inssrt Selection Took Window Help

|DSAS| @y o sl o 0K sedsdme [lefoie < B
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[Jea-e9
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How Does It Work

Yield variability can be due to the differences in physical and chemical soil properties. The
inconsistency of various soil properties can be evaluated using the results of laboratory analyses
performed on samples obtained from various locations within a field.

Field data are collected at dispersed locations. An adequate number of samples should be
collected to accurately characterize the nutrient levels in soil. Sampling near farm lanes and field
boundaries should be avoided as the soil varies due to external factors. A predicted surface is
then generated from these dispersed point values by interpolation. The assumption that makes
interpolation a viable option is that spatially distributed objects are spatially correlated which
means things that are close together tend to have similar characteristics. The values of points
close to sampled points are more likely to be similar than those that are farther apart. A typical
use for point interpolation is to create an elevation surface from a set of sample measurements.
For example if it is snowing on one side of the street there is high chance that it is snowing on the
other side of the street. The chance of snow reduces across the town and further reduces across
the state.

The illustrations below show the distribution and values of sample points and the raster generated
from them. The left illustration shows a point dataset of known P value in soil property. The
illustration on the right shows a raster interpolated from these points. Unknown values are
predicted with a mathematical formula that uses the values of nearby known points.
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Surface interpolation functions make predictions from sample measurements for all locations in a
raster dataset, whether or not a measurement has been taken at the location. There are a variety
of ways to derive a prediction for each location; each method is referred to as a model. With each
model, there are different assumptions made of the data, and certain models are more applicable
for specific data—for example, one model may account for local variation better than another.
Each model produces predictions using different calculations.

The interpolation tools are generally divided into deterministic and geostatistical methods. IDW,
Spline, and Trend are deterministic and Kriging is a geostatistical method. The Inverse Distance
Weighted (IDW) and Spline methods are referred to as deterministic interpolation methods
because they assign values to locations based on the surrounding measured values and on
specified mathematical formulas that determine the smoothness of the resulting surface. IDW
interpolates a surface from points using an inverse distance weighted technique.
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Additional Challenge

Create an interpolated surface using pH value of soil? What will the surface with OM (organic
matter) values look like?

Vocabulary

Crop yield is a measure of the output per unit area of land under cultivation

Grid: Equally sized square cells arranged in rows and columns. Each cell contains a value for the
feature it covers.

Interpolation is a estimating an unknown value that falls between known values.

Inverse Distance Weighted(IDW) is an interpolation technique that determines cell values in a
grid with a set of sample points that have been weighted so that the farther a point is from the cell
being evaluated, the less important it is in calculating the cell’'s value.

Surface model is an approximation of a surface, generalized from sample data

Soil pH is a measure of the acidity of the soil. It affects the availability of soil nutrients.
Phosphorus(P) in soil is an important element in the development of plant reproductive parts.

Viacheslav Adamchuk and Shana Thomas
Phone: 402-472-8431

E-mail: vadamchuk2@unl.edu

Last updated: November 11, 2008
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